Subscribe:

Ads 468x60px

Wednesday, July 11, 2012

cvBlob in Windows7 using VisualStudio2010

Hi all
  I ported cvblob lib to Windows 7 using VS2010. This lib will work well  in Linux, but there are some issues on Windows. I tried some fixes and corrected it
I used OpenCV 2.4.2,
 VS2010,
Windows 7


I am giving the screenshots below.


Setup  cvlib.lib

1)Setting an empty project. 

2)Configuration Type to Static library(.lib)




3)Include directory setup



4)Include directory setup ....



5)Linker Directories

6)Additional dependancies



After building you will get a static library called cvblob.lib


Blob test example setup
------------------


Take a empty project called cvblob_test and add a source file called test 




1)Include directories setup


2)Include directories setup continoue ...


3)Linker setup
Add cvblob.lib path in linker directories


6)Additional dependencies
Add cvblob.lib



Copy the test_example.cpp into the test.cpp file and build in release mode. This example will track the red objects as shown below

Output Video
--------------


Thanks

7 comments:

afzal said...

good work

Lentin Joseph said...

@Afsal ..Thanks :)

Dmitry said...

What type of project do we start with? MFC DLL, Class LIbrary???

Can you please post the compiled DLL and Lib Files

Shelly Huberman said...

Hello Joseph,
Lately I have installed cvblob.lib on my "opencv" directory.
I have encountered a problem on the next step "Blob test example setup": on step 1 the first folder on the list "G:\Other\cvblob\cvblob_\cvblob" does not exist in my pc, so I couldn't upload it.
As a result – I could not compile the test and I received errors.
I want to emphasize that I could upload all the other directories on your list, so the problem is to find out why "G:\Other\cvblob\cvblob_\cvblob" is not in my pc and how to create it.
I would be grateful if you could show me how to solve the problem.
Best regards,

Shelly.

Anonymous said...

This post is a shit . You should have present it a better way so people can understand. What could have been a nice tutorial is now a toltal shit

Hassan Javed said...


I am trying to build cvblobslib in VS2010 with windows 7. The cvblobs wiki page here

http://opencv.willowgarage.com/wiki/cvBlobsLib#Build_intructions

describes that to build you need to just open the project file and build it.However, for me working in VS2010 on windows 7 this does not build and gives the following error:

`c:\users\administrator\desktop\cvblobslib_opencv_v8_3\blob.h(21): fatal error C1083: Cannot open include file: 'cxcore.h': No such file or directory
1> ComponentLabeling.cpp

1>c:\users\administrator\desktop\cvblobslib_opencv_v8_3\blobcontour.h(6): fatal error C1083: Cannot open include file: 'cv.h': No such file or directory
1> BlobResult.cpp

1>c:\users\administrator\desktop\cvblobslib_opencv_v8_3\blobresult.h(24): fatal error C1083: Cannot open include file: 'cxcore.h': No such file or directory
1> BlobOperators.cpp

1>c:\users\administrator\desktop\cvblobslib_opencv_v8_3\blob.h(21): fatal error C1083: Cannot open include file: 'cxcore.h': No such file or directory
1> BlobContour.cpp

1>c:\users\administrator\desktop\cvblobslib_opencv_v8_3\blobcontour.h(6): fatal error C1083: Cannot open include file: 'cv.h': No such file or directory
1> Generating Code...
1>
1>Build FAILED.`

How do I remove these errors?There have been similar questions here but no-one has answered these satisfactorily.

Alejandro P.M. said...

Thank you very much for this tutorial!
It helped me a lot.

Post a Comment